Old versions of s2Member Framework and s2Member Pro can be downloaded from the Release Archive.

Important Note: When installing s2Member Framework and the s2Member Pro add-on, you must make sure that you install identical versions (e.g., s2Member Pro v150311 will only work with s2Member Framework v150311); the versions for both must always match.

You can find older versions here: